summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5-sip
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt5-sip')
-rw-r--r--dev-python/PyQt5-sip/Manifest2
-rw-r--r--dev-python/PyQt5-sip/PyQt5-sip-12.13.0-r1.ebuild22
-rw-r--r--dev-python/PyQt5-sip/files/PyQt5-sip-12.13.0-c99.patch16
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/PyQt5-sip/Manifest b/dev-python/PyQt5-sip/Manifest
index 8d850fa4fda8..05360f7c47e1 100644
--- a/dev-python/PyQt5-sip/Manifest
+++ b/dev-python/PyQt5-sip/Manifest
@@ -1,3 +1,5 @@
+AUX PyQt5-sip-12.13.0-c99.patch 522 BLAKE2B 72f6d0a501fcc7f43cb11291833b7714ba2acc35813c4762a95ec2ce5b95ba955cfa7f5501e38e24f348b73e835487e151082c205c4d434044362b80d2a0f44a SHA512 768c88fab736a57f55e4adb4843b918f84ecf0e976246abbf83a9b45d69a1e6729e738eb4cbac3553ae76a36ace64abf798e073f8ec88fdb3065583a38801773
DIST PyQt5_sip-12.13.0.tar.gz 123225 BLAKE2B e3b7233e5405f7b24de157e1f0ed0f2ff47a9c331a76672892d8a7adc8aba8c7b738354d9f1c2fe9c29501b5bfe8c6302307c6731273b980a04dd327048a3a94 SHA512 ef363b21899f6d089fbc6d5adf700dc6c8838501343070ed1cf0826e05dd860343eba608d5aee5d8bece39b8ddca1f37866bb56aa07db18384ac0a372ca3532f
+EBUILD PyQt5-sip-12.13.0-r1.ebuild 539 BLAKE2B 18564f0f53ba86b4d0c2184c16e2156f251c903eded09dff46b12a4dbd241c7a5c5eee2fb30282827f10c18e41c0eb2cbcd731e5886478d8e07be799c54b1764 SHA512 687b7342228b605370539673ee0cf3722bdf4e65a8c54ac46efa9993e2649d03fbb7f84486ceaed9b371f5ed6902a6236f09103ac2b4032378cfcf5fd295b7ad
EBUILD PyQt5-sip-12.13.0.ebuild 478 BLAKE2B 3e33d4ac00af1d9dc9ffb52f3bb978ba9f5513b56833c018ddcee4d174bc187f4f4d34087ce323f388b8931caff780511d5a458f07e38acf6f674b52fe771e55 SHA512 842d0c36c2807201c02ce5f9862d106dfb0ac9fec50b534102c46756dcafcfacc939eecff6e3a23c2c14401aeb9ef1d4dcd612845ee28ff96223a4a151a8c86c
MISC metadata.xml 649 BLAKE2B 0a6faee65b39f122f65965490284b17856ba6d86537f3f3780f8604366739c346b01e29e933a91c7edb5ff898e5d51a10e4bf288228d1943a1c9e9970eac4c86 SHA512 3af9be87db6da5cb071f4025cd6fc1964a4b0629ebe93239f6c5a3734d4ef8ef06e652abbac5c9bd86f882a6235bf3b1f0fec6f0035c77ea42571e47c6045e29
diff --git a/dev-python/PyQt5-sip/PyQt5-sip-12.13.0-r1.ebuild b/dev-python/PyQt5-sip/PyQt5-sip-12.13.0-r1.ebuild
new file mode 100644
index 000000000000..ef695eed82eb
--- /dev/null
+++ b/dev-python/PyQt5-sip/PyQt5-sip-12.13.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/_}
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip extension module for PyQt5"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/PyQt5-sip-12.13.0-c99.patch"
+)
diff --git a/dev-python/PyQt5-sip/files/PyQt5-sip-12.13.0-c99.patch b/dev-python/PyQt5-sip/files/PyQt5-sip-12.13.0-c99.patch
new file mode 100644
index 000000000000..b1fd2470758c
--- /dev/null
+++ b/dev-python/PyQt5-sip/files/PyQt5-sip-12.13.0-c99.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/919000
+https://www.riverbankcomputing.com/hg/sip/rev/afc99fa84d0d
+
+diff --git a/siplib.c b/siplib.c
+index 8b0a6d5..d996a9c 100644
+--- a/siplib.c
++++ b/siplib.c
+@@ -3902,7 +3902,7 @@ static int parsePass1(PyObject **parseErrp, sipSimpleWrapper **selfp,
+ {
+ case '#':
+ /* A ctor has an argument with the /Transfer/ annotation. */
+- *selfp = va_arg(va, PyObject *);
++ *selfp = (sipSimpleWrapper *) va_arg(va, PyObject *);
+ break;
+
+ case 'B':