summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.7.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index c04c1636f253..7f9773ffdb0d 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,7 @@
DIST Nuitka-1.4.5.tar.gz 4131887 BLAKE2B b4eaea811a98f1ea5618a477841e2fd2ef41eb4c78635576fadae8a645456f9d47741d1b8c0c102e2774e1802d210785f31a10889d87441693215d84d06cabdd SHA512 fc628be6579f2b290d126fc9f16e16a2fcdd5457a28cb2caa1b2d4e23426933e502a3487485e54cf4e0f67d2d5bca97567d5502070e7ad46a03c513a1f6f9c9f
DIST Nuitka-1.4.6.tar.gz 4131786 BLAKE2B a72d8b8925dfdd7ca6416912d725cd711c1f8cedabbdc4ea1764645d935529c2b1561c561c6fe8b8cd2babdadd0b6cd3c239ff7e844bd745cebc3b2d94cfbd63 SHA512 883806d787bd35c687bd0771a0f3182d1d157c4c0f403c5b60a03536631823fbdfbaf32c3c29f484aa7de3dacf01056183607109036f60c5602ab08072d8e40d
+DIST Nuitka-1.4.7.tar.gz 4132335 BLAKE2B 5c9e653c8ffa7ad9e757a20d4008e4e2a3083cfefcbce826f0904c0281a9be95dbfb78ad1aab2dd0819b9bf3a800a3b35ee422e38672655fdd900162f9c0d090 SHA512 fb219f5a53bc173365d23f4eae0814fa051c1312bc732ac2b717924dd2336bf140af0237834062223294c840f63b6b4766422f8fd189151ab73877eeb9c39ee6
EBUILD Nuitka-1.4.5.ebuild 1165 BLAKE2B 2a084c0bddcc11e5355533e2f03a5477932c304bddbef48a27817f16334db4e42bfc5b95988c4a0092336a5560d79089b00aefb2399a22ba6ceaa0180a53f045 SHA512 65f370ff9c5bfa6b0cd9b89c9e4173c03136652364cd20e4fe2c320af203c14fd317e08e6d16b06ed0db0856189f5374eba309288b33cdee05c9d9530ac18ad4
EBUILD Nuitka-1.4.6.ebuild 1165 BLAKE2B 2a084c0bddcc11e5355533e2f03a5477932c304bddbef48a27817f16334db4e42bfc5b95988c4a0092336a5560d79089b00aefb2399a22ba6ceaa0180a53f045 SHA512 65f370ff9c5bfa6b0cd9b89c9e4173c03136652364cd20e4fe2c320af203c14fd317e08e6d16b06ed0db0856189f5374eba309288b33cdee05c9d9530ac18ad4
+EBUILD Nuitka-1.4.7.ebuild 1165 BLAKE2B 2a084c0bddcc11e5355533e2f03a5477932c304bddbef48a27817f16334db4e42bfc5b95988c4a0092336a5560d79089b00aefb2399a22ba6ceaa0180a53f045 SHA512 65f370ff9c5bfa6b0cd9b89c9e4173c03136652364cd20e4fe2c320af203c14fd317e08e6d16b06ed0db0856189f5374eba309288b33cdee05c9d9530ac18ad4
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-1.4.7.ebuild b/dev-python/Nuitka/Nuitka-1.4.7.ebuild
new file mode 100644
index 000000000000..6f373b0022b9
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.4.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}