summaryrefslogtreecommitdiff
path: root/dev-python/BitVector/BitVector-3.4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/BitVector/BitVector-3.4.8.ebuild')
-rw-r--r--dev-python/BitVector/BitVector-3.4.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.4.8.ebuild b/dev-python/BitVector/BitVector-3.4.8.ebuild
new file mode 100644
index 000000000000..8952469258c1
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.4.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="https://engineering.purdue.edu/kak/dist/ https://pypi.org/project/BitVector/"
+SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}