summaryrefslogtreecommitdiff
path: root/dev-python/Babel/Babel-2.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Babel/Babel-2.8.1.ebuild')
-rw-r--r--dev-python/Babel/Babel-2.8.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/Babel/Babel-2.8.1.ebuild b/dev-python/Babel/Babel-2.8.1.ebuild
deleted file mode 100644
index 59a1c0b8d639..000000000000
--- a/dev-python/Babel/Babel-2.8.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="https://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/Babel-2.8.0-py39.patch
- "${FILESDIR}"/Babel-2.9.0-pypy3.patch
-)
-
-src_test() {
- local -x TZ=UTC
- distutils-r1_src_test
-}