summaryrefslogtreecommitdiff
path: root/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild')
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
new file mode 100644
index 000000000000..2da5b5180736
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src || die
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins -r src/*
+
+ einstalldocs
+}