summaryrefslogtreecommitdiff
path: root/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.3.ebuild')
-rw-r--r--dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.3.ebuild b/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.3.ebuild
new file mode 100644
index 000000000000..57a47c3aee00
--- /dev/null
+++ b/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="DirectoryScanner"
+
+DESCRIPTION="A recursive directory scanner and filter"
+HOMEPAGE="https://github.com/theseer/DirectoryScanner"
+SRC_URI="https://github.com/theseer/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/php/TheSeer/${MY_PN}
+ doins -r src/*
+
+ einstalldocs
+}