summaryrefslogtreecommitdiff
path: root/dev-php/symfony-finder
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/symfony-finder')
-rw-r--r--dev-php/symfony-finder/Manifest3
-rw-r--r--dev-php/symfony-finder/files/symfony-finder-3.4.28-skip-file-time-sort-tests.patch20
-rw-r--r--dev-php/symfony-finder/symfony-finder-3.4.28.ebuild39
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-php/symfony-finder/Manifest b/dev-php/symfony-finder/Manifest
index f5d2d83fac3b..05f0451eb451 100644
--- a/dev-php/symfony-finder/Manifest
+++ b/dev-php/symfony-finder/Manifest
@@ -1,5 +1,8 @@
AUX autoload.php 272 BLAKE2B 53ab5f647a53f82edd22bec0b29d10ac89a488bdee8cc67365190887c65f2233f72a2db01a82f7bdace894fb0a4ed1b31b3b7c6856cf36e7900512d4afde7063 SHA512 b10296ebdf173be6e8b4d98013888778269d08915e1e30f1c00f59dbfb15af5b8a39d59a302b3ea65ba811d8c51c975b876fff1a3adf2a6cf6cf129172525f17
AUX skip-file-time-sort-tests.patch 1211 BLAKE2B 84e77e610c1c57e54063d50e7ed4fe70e7678954ea7917c9096a723aac16906427e1f9a27092e3dc8e908cd9b53d266d7651704469ab29832ab596792edf98e4 SHA512 bf8e229ab4d9afbe991c60710eefc4a741ee87671dd3fef386548cacfff160e56b455437c9af94dc1e88253111d10edb3133762c781673e962428150589231e3
+AUX symfony-finder-3.4.28-skip-file-time-sort-tests.patch 1026 BLAKE2B aab5d755792961baf53217710f9d196663f5dbcf96cb524a5850cf681abdef6c0b60e2af08e4c7e01f135f95d750d3c0532e190dd009f7c9213adc70085b2da2 SHA512 836689dce3d9ae230a0d2d8ae7df6f9cd592853f14c6b56f0daffe9ee474fd3ecdedbd05bd9a1e344d6af5c2ec6ba04c1fb5fdbc60e70a843e6e02ae3de922c1
DIST symfony-finder-3.2.8.tar.gz 24452 BLAKE2B eed88ea672381fa3a0fef9390109fa7b89b8de87f4e0174fcb24c009044818b7c56846eec0b3240eed1c05fe7d682713fdd41c84e5d766cc2632e5576b38b741 SHA512 7eff457c6c70bf58b4af7e9adbeeb68a1ad684b95510d929f137545be6b755ece37949687f4de27c7fb4d5f208e30c6b0b3a32a804f7a6a6b8ed0d4ed7dfd9cd
+DIST symfony-finder-3.4.28.tar.gz 25618 BLAKE2B 592a10a5e8d7f1782242d79bc11ebfde6d528025a65bb18d5c36b238c418a3df10e637a285d0859bb79ab152aafdad5d61d32396efed6f6fe0e800aff03fae69 SHA512 5b1754e47eb484fddfb1d29f181efaabb371e62c2afe5c7c1d0552ac82de81aff0fbc6594498b859b64cd34cf35e57cf29110d59e5f376263f1b136a4d184b69
EBUILD symfony-finder-3.2.8.ebuild 936 BLAKE2B c291d2c2b89cab1a8d498e36a2cb7e313512a7914afed8f20c220714a1badca4c0bebbec06040f7776a4425ec9d9e1450e89acefb03377c6d77b8c3790b1be6b SHA512 0bbf0ec089f3c9772324bcb0a67644ea6a5ab9df95b6350ca000483b9d0bf59ffda0bda34d5a68b73e302480e9d4dfa2d2f1dc592a80e1cd2210229f613164c5
+EBUILD symfony-finder-3.4.28.ebuild 946 BLAKE2B ad129b07fb9bf98f235c7e70d71632e989a27f615148c7a185f43a8a3c8b8456490afbbb9cd5e94aef60166a3dfc4f98c23c3c1cb6d55ad28bf40fd8ed208058 SHA512 b43d8e1b0e73deadd7b5f6b344c05663de370a0a57ef6939b660afcd8dbd8e471962404ac4abc577ce790af61c4c1a2716fee55aaf4a244c9e068b45054c7b42
MISC metadata.xml 685 BLAKE2B feba013286ccce28abfb477e4c32c105bced39a175c00aab8c2413144100758914f93380418fbf9acce9c44ea9887b34b77cc674240edcac687449b1c5a7e36c SHA512 664abc5b0e4894c547f4d39ed3cc3c4f4b6526e0ad9dec4a83f43410121b2aaeccc969bf4393a899d309e71c21fd6e06df7f4547927a8ae1ee0b1382a8c5dc92
diff --git a/dev-php/symfony-finder/files/symfony-finder-3.4.28-skip-file-time-sort-tests.patch b/dev-php/symfony-finder/files/symfony-finder-3.4.28-skip-file-time-sort-tests.patch
new file mode 100644
index 000000000000..25729f89e1ef
--- /dev/null
+++ b/dev-php/symfony-finder/files/symfony-finder-3.4.28-skip-file-time-sort-tests.patch
@@ -0,0 +1,20 @@
+There's one set of tests that tries to sort an array of files by their
+access and modification times, and that doesn't work if your filesystem
+is mounted with noatime (a lot of our users do that).
+
+This should probably be fixed upstream, and has been reported here:
+
+https://github.com/symfony/symfony/issues/17489
+
+--- a/Tests/Iterator/SortableIteratorTest.php
++++ b/Tests/Iterator/SortableIteratorTest.php
+@@ -65,7 +65,8 @@ class SortableIteratorTest extends RealIteratorTestCase
+ if ('\\' === \DIRECTORY_SEPARATOR && SortableIterator::SORT_BY_MODIFIED_TIME !== $mode) {
+ $this->markTestSkipped('Sorting by atime or ctime is not supported on Windows');
+ }
+- $this->assertOrderedIteratorForGroups($expected, $iterator);
++ // $this->assertOrderedIteratorForGroups($expected, $iterator);
++ $this->markTestSkipped('Sorting by time is failure-prone on Gentoo');
+ } else {
+ $this->assertOrderedIterator($expected, $iterator);
+ }
diff --git a/dev-php/symfony-finder/symfony-finder-3.4.28.ebuild b/dev-php/symfony-finder/symfony-finder-3.4.28.ebuild
new file mode 100644
index 000000000000..40b3be06d7a9
--- /dev/null
+++ b/dev-php/symfony-finder/symfony-finder-3.4.28.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Symfony Finder Component"
+HOMEPAGE="https://github.com/symfony/finder"
+SRC_URI="https://github.com/symfony/finder/archive/v${PV}.tar.gz -> symfony-finder-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/finder-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.28-skip-file-time-sort-tests.patch )
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Finder"
+ doins -r Comparator Exception Iterator
+ doins *.php "${FILESDIR}"/autoload.php
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
+}