summaryrefslogtreecommitdiff
path: root/dev-php/phptal/phptal-1.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phptal/phptal-1.3.1.ebuild')
-rw-r--r--dev-php/phptal/phptal-1.3.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-php/phptal/phptal-1.3.1.ebuild b/dev-php/phptal/phptal-1.3.1.ebuild
deleted file mode 100644
index 852ecd7ec345..000000000000
--- a/dev-php/phptal/phptal-1.3.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_LIB_NAME="PHPTAL"
-
-DESCRIPTION="A templating engine for PHP5 that implements Zope Page Templates syntax"
-HOMEPAGE="https://phptal.org/"
-SRC_URI="https://github.com/${PN}/${PHP_LIB_NAME}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-lang/php:*"
-DEPEND="test? ( ${RDEPEND} <dev-php/phpunit-6 )"
-
-S="${WORKDIR}/${PHP_LIB_NAME}-${PV}"
-
-src_compile() { :; }
-
-src_install() {
- insinto /usr/share/php/${PN}
- doins -r "classes/${PHP_LIB_NAME}"
- doins classes/PHPTAL.php tools/phptal_lint.php
-
- dodoc README.md
-}
-
-src_test() {
- [[ -z $(locale -a |grep en_GB) ]] && ewarn "Tests require en_GB locale to complete"
- phpunit || die
-}