summaryrefslogtreecommitdiff
path: root/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild')
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild b/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
index fad568565135..40bb1203cafe 100644
--- a/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -28,7 +28,7 @@ RESTRICT='test'
PATCHES=( "${FILESDIR}/8.0-patches-20211123.patch" )
src_prepare() {
- if use php_targets_php8-0 || use php_targets_php8-1 ; then
+ if use php_targets_php8-1 ; then
php-ext-source-r3_src_prepare
else
default
@@ -36,14 +36,14 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php8-0 || use php_targets_php8-1 ; then
+ if use php_targets_php8-1 ; then
local PHP_EXT_ECONF_ARGS=( --enable-memcache --with-zlib-dir="${EPREFIX}/usr" $(use_enable session memcache-session) )
php-ext-source-r3_src_configure
fi
}
src_install() {
- if use php_targets_php8-0 || use php_targets_php8-1 ; then
+ if use php_targets_php8-1 ; then
php-ext-pecl-r3_src_install
php-ext-source-r3_addtoinifiles "memcache.allow_failover" "true"