summaryrefslogtreecommitdiff
path: root/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild')
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild b/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
index db8ac9043284..976d95d6c8fa 100644
--- a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -9,7 +9,7 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"
-USE_PHP="php8-0 php8-1"
+USE_PHP="php8-1"
inherit php-ext-pecl-r3
@@ -22,14 +22,13 @@ IUSE="ssl curl_ssl_gnutls +curl_ssl_openssl"
COMMON_DEPEND="app-arch/brotli:=
dev-libs/libevent
- >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-0(-)?,php_targets_php8-1(-)?]
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=] )
!ssl? ( net-misc/curl[-ssl] )
"
DEPEND="
- php_targets_php8-0? ( ${COMMON_DEPEND} dev-lang/php:8.0[session(-),iconv(-)] )
php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )"
RDEPEND="${DEPEND}"