summaryrefslogtreecommitdiff
path: root/dev-php/PHPMailer
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PHPMailer')
-rw-r--r--dev-php/PHPMailer/Manifest2
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.5.1.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 404854685efb..03d625f88f13 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,3 +1,5 @@
DIST PHPMailer-6.5.0.tar.gz 99073 BLAKE2B dcb917233da29ab45305f7cf0405f9bb384bd4f98f062a74d94a168868d0cd92017e555bf8e7139130dd669e0a04917e3789c548b5165112d591aa403bfd56b8 SHA512 0632ec8b80c30393b00aebbadde7dd032eb2553232a100a74d69b6ed6465adf1eb3a4acca0aaf040665a978e7507aee9350b092336056ccb5306fbaea4640376
+DIST PHPMailer-6.5.1.tar.gz 99913 BLAKE2B bf51e2caa0ff1d113d6f96f5c1ee055bacd40f8a251302452eb2ebbe06d1f926935b5d85c1b9e85d115180473b76077f753f0c8af04aa86c86db3431c8a412f2 SHA512 0f8e9e3368edfdb67c701a0f42c548379c9528a90bc016444ebdc9614967ca421fa706b5f1b2de89a91fa98f7e535fb67da578ac6ba1b73f673ba7b45a198f0e
EBUILD PHPMailer-6.5.0.ebuild 2195 BLAKE2B 54fd8e6fb8cf1e7907a2055e2e8b035638c46c8c0136be68b5889b1dbcfe82206575b02f1302a5a22dca3171d9b79a03cb71ebbfe9565aaf7c298eca4ec47b20 SHA512 71791e9219d29b6006e0092fa82f646770b8703891be17bc6559f8c0ce4441c3efa37ec2619d807ee51185a54da259919261e94b2d38372a766c57624cca6600
+EBUILD PHPMailer-6.5.1.ebuild 2195 BLAKE2B 54fd8e6fb8cf1e7907a2055e2e8b035638c46c8c0136be68b5889b1dbcfe82206575b02f1302a5a22dca3171d9b79a03cb71ebbfe9565aaf7c298eca4ec47b20 SHA512 71791e9219d29b6006e0092fa82f646770b8703891be17bc6559f8c0ce4441c3efa37ec2619d807ee51185a54da259919261e94b2d38372a766c57624cca6600
MISC metadata.xml 446 BLAKE2B 178ea98081e664641c7a8632a1c7dac9b5cac8992b0b945208f5ef654633340daced2473bbdc342b70d8b168ac2206ba132f7ab9601f61b5436f3eb3e0441ca1 SHA512 3dfce858cb0e00b526f04a5764a6173d4711db4f21f52b6d827b82f1cddea4e33f533e645dae95d0bb6a69699b00520a414f2e322c76b56aee1e4ea047bb4bb5
diff --git a/dev-php/PHPMailer/PHPMailer-6.5.1.ebuild b/dev-php/PHPMailer/PHPMailer-6.5.1.ebuild
new file mode 100644
index 000000000000..48dc349297f3
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.5.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ default
+
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+}
+
+src_compile() {
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}