summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-HTML_Template_Sigma
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-HTML_Template_Sigma')
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/Manifest4
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild21
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch42
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/metadata.xml8
4 files changed, 0 insertions, 75 deletions
diff --git a/dev-php/PEAR-HTML_Template_Sigma/Manifest b/dev-php/PEAR-HTML_Template_Sigma/Manifest
deleted file mode 100644
index bb8b7c81965d..000000000000
--- a/dev-php/PEAR-HTML_Template_Sigma/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX HTML_Template_Sigma-1.3.0-php7.patch 2155 BLAKE2B 1e46e49bf5bf54719635736f8c5f50c6c123c5777fbcf59c1fb5129f068d4947c0e0669b6df76de80b2cd54ec8674a85174f1acfa3a2601abd82eab6bb30d416 SHA512 ea9399d7b7de2361a11b2cc2e89d534b4289ecd656c9b5d99618d4faef9ad7b39e87884d5c720b62a8d55c58ce66b35ee014d010bef5a8ec5cc4b2884b894eda
-DIST HTML_Template_Sigma-1.3.0.tgz 30185 BLAKE2B 62d91d803a088c45c662191cc4fe544d2ef694577a3250a5bc19bc7b41640fc695be95c075c8c3f53e3ebc03fa7d9d38135d607c408ff3d6cb0f1ad11855b740 SHA512 586068325a3320e2778131c1da98d6179d2385d2d73308b0ea1e8df3e0de23f869e03d74454752631998ef3411d8e8b37feab93c6c7b9f51ae4bedb48155e3ed
-EBUILD PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild 531 BLAKE2B 57a7075bf2d21670b1d9101942588fe09c002f674cbbafe552eb25b390db2c9db2e8ff0d505c3fab0ad9ee12fd0b76ad5f2f8927635646d368adf32ffa1700ef SHA512 8abccef9d018b6cbad6333f3c2c3420437020cf52a85a5de43e9821c59fd3d6022c247f0b3174bb2c80755a523a6d458c443065a7f8660c6dffc8f4919d776d5
-MISC metadata.xml 236 BLAKE2B 55612da78a71f8cee31c387a5862636996734210d765fac66d8c7706acc5151e6a9e7ff5123aeb097c911495c6220ba3b5d2f1355f46e8ab6bdb240e1697e26d SHA512 2782b20a65dca663ff7c64b7e67db05641abed478fd5996e5750b2e52ba870829f89125baa8967dd29fd20ef9b46ad233b0dd08801308b7756717ec2f292446c
diff --git a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild
deleted file mode 100644
index aa685f6b9df3..000000000000
--- a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2
-
-DESCRIPTION="An implementation of Integrated Templates API with template 'compilation' added"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-lang/php:*[ctype]"
-DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
-PATCHES=( "${FILESDIR}/HTML_Template_Sigma-1.3.0-php7.patch" )
-
-src_test() {
- phpunit tests/AllTests.php || die
-}
diff --git a/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch b/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch
deleted file mode 100644
index ffb95e208467..000000000000
--- a/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -aurN a/HTML/Template/Sigma.php b/HTML/Template/Sigma.php
---- a/HTML/Template/Sigma.php 2014-01-13 04:33:52.000000000 -0500
-+++ b/HTML/Template/Sigma.php 2018-02-19 09:29:52.995013991 -0500
-@@ -384,6 +384,26 @@
- *
- * @see setRoot(), setCacheRoot()
- */
-+ function __construct($root = '', $cacheRoot = '')
-+ {
-+ // the class is inherited from PEAR to be able to use $this->setErrorHandling()
-+ parent::__construct();
-+ $this->variablesRegExp = '@' . $this->openingDelimiter . '(' . $this->variablenameRegExp . ')' .
-+ '(:(' . $this->functionnameRegExp . '))?' . $this->closingDelimiter . '@sm';
-+ $this->removeVariablesRegExp = '@' . $this->openingDelimiter . '\s*(' . $this->variablenameRegExp . ')\s*'
-+ . $this->closingDelimiter . '@sm';
-+ $this->blockRegExp = '@<!--\s+BEGIN\s+(' . $this->blocknameRegExp
-+ . ')\s+-->(.*)<!--\s+END\s+\1\s+-->@sm';
-+ $this->functionRegExp = '@' . $this->functionPrefix . '(' . $this->functionnameRegExp . ')\s*\(@sm';
-+ $this->setRoot($root);
-+ $this->setCacheRoot($cacheRoot);
-+
-+ $this->setCallbackFunction('h', array(&$this, '_htmlspecialchars'));
-+ $this->setCallbackFunction('e', array(&$this, '_htmlentities'));
-+ $this->setCallbackFunction('u', 'urlencode');
-+ $this->setCallbackFunction('r', 'rawurlencode');
-+ $this->setCallbackFunction('j', array(&$this, '_jsEscape'));
-+ }
- function HTML_Template_Sigma($root = '', $cacheRoot = '')
- {
- // the class is inherited from PEAR to be able to use $this->setErrorHandling()
-diff -aurN a/tests/AllTests.php b/tests/AllTests.php
---- a/tests/AllTests.php 2014-01-13 04:33:52.000000000 -0500
-+++ b/tests/AllTests.php 2018-02-19 09:37:14.071972780 -0500
-@@ -24,8 +24,6 @@
- define('PHPUnit_MAIN_METHOD', 'HTML_Template_Sigma_AllTests::main');
- }
-
--require_once 'PHPUnit/Autoload.php';
--
- /**
- * Class for file / directory manipulation from PEAR package
- */
diff --git a/dev-php/PEAR-HTML_Template_Sigma/metadata.xml b/dev-php/PEAR-HTML_Template_Sigma/metadata.xml
deleted file mode 100644
index 77793b997e9e..000000000000
--- a/dev-php/PEAR-HTML_Template_Sigma/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
-</pkgmetadata>