summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Exception
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Exception')
-rw-r--r--dev-php/PEAR-Exception/Manifest4
-rw-r--r--dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild29
-rw-r--r--dev-php/PEAR-Exception/metadata.xml1
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-php/PEAR-Exception/Manifest b/dev-php/PEAR-Exception/Manifest
index 3ff8356b34ff..2a7a97b7aa68 100644
--- a/dev-php/PEAR-Exception/Manifest
+++ b/dev-php/PEAR-Exception/Manifest
@@ -1,3 +1,5 @@
DIST PEAR_Exception-1.0.0.tgz 5270 BLAKE2B f6f6874083fcef2453e1d07e1ee3e900e4f7d18eca8e9a9eda9891492dd3fc1e31eb13944031e82044f976f1070463a3b099a8223d2dabb2da109bb123997f5a SHA512 f2078186fdad6c6ca59ac462a24f7f9689bea08d30f786acb7779d52cd433e490c752ba0a263067d869151b0c051cded327cb3477a039c5de68c854bff002b58
+DIST PEAR_Exception-1.0.2.tgz 5458 BLAKE2B f6e7bc452729ec4419650a0fbd6ef091dd5ec1b91804e1b59c598e44d3c04bf043084e385daa56fd1f6c012090010490922627a465061fe57ef9d74a49960e91 SHA512 80022c03bb665307a9feea88312301c86c903c5b8737559f59fc0028a08976976dd21e19a7dc805c27ec41f90ebd310012cd56ba2c2c006cf0df7cea69323a91
EBUILD PEAR-Exception-1.0.0.ebuild 684 BLAKE2B c8d0efb6b79cf6a3cf25430bb35f1ad4d2dde38739310972874179c2fed867c36bd72fec99a483278a5a094d4258f82e918ae32a00abbc4459754d861b7116b9 SHA512 911926590096355f403971af90976eb9f156e3ed08efba7b6570fa1636145a9af693c9f29b3f2170b4aa3a4ebf34e424e5ab03eda554bd39a958f9314fab42c8
-MISC metadata.xml 387 BLAKE2B 6252502a9c87fbd9661d95aadfb5e0c97f585eb63a196de865690e09216c9f0e1cc6d25035c014a0d59a69dfd605a30ddb88728c4e7cec295a810fb70c36c912 SHA512 1b04eb2e9c576527651ba9a35693f3cee64b519d288da309e3e3ae2f8ba0ec7d35fb1238d7fe70242fd66983884e8121ee17f09902a2942c24025f54cea0edea
+EBUILD PEAR-Exception-1.0.2.ebuild 712 BLAKE2B 90800fbfadf0e06a5d17997144a6bda5a05295f7093f305623ad2da5f51637a96e879d14e08b4092cb723c8bc8cf2af00b4aba54135a6682a3be98e857a06cca SHA512 d29422bc0316c708b25f2381d976bfc352896ff1f1b839bb6621788631c9829c0d78735f5fd3340f541b181712c48bf4822e339bcc81d6337fdd9441742ad8bd
+MISC metadata.xml 412 BLAKE2B a41bdeb206a4643c07b5d87d5754f29de975b12092eccecfe4387e9f66d53825fc8ad75eb31dd851f32e5365e56e4070fc08a8ed5fa0f29e73d9b32706e27950 SHA512 4d30e459f1dc4e9b186800ae528a56114b6e1eedca7fd698407708cdc44fd4ac6f609d4b8dca6a29f6b91faade8d12efcdf5e73e94dd355c930d1e4dd0e9113e
diff --git a/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild b/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
new file mode 100644
index 000000000000..2a4a155c793d
--- /dev/null
+++ b/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The PEAR Exception base class"
+HOMEPAGE="https://pear.php.net/package/PEAR_Exception"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-lang/php:*
+ !<=dev-php/PEAR-PEAR-1.10.3-r1"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+src_test() {
+ phpunit --do-not-cache-result tests || die "test suite failed"
+}
diff --git a/dev-php/PEAR-Exception/metadata.xml b/dev-php/PEAR-Exception/metadata.xml
index d627ee6970d8..0d4a6d80c8fa 100644
--- a/dev-php/PEAR-Exception/metadata.xml
+++ b/dev-php/PEAR-Exception/metadata.xml
@@ -9,4 +9,5 @@
<remote-id type="github">pear/pear_exception</remote-id>
<remote-id type="pear">PEAR_Exception</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>