summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild')
-rw-r--r--dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild b/dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild
new file mode 100644
index 000000000000..1e96bfe6f5a9
--- /dev/null
+++ b/dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DESCRIPTION="Database abstraction layer for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR, and also
+ # a working version of the cli SAPI eselected.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}