summaryrefslogtreecommitdiff
path: root/dev-perl/XML-Entities/XML-Entities-1.0.200-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/XML-Entities/XML-Entities-1.0.200-r1.ebuild')
-rw-r--r--dev-perl/XML-Entities/XML-Entities-1.0.200-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/XML-Entities/XML-Entities-1.0.200-r1.ebuild b/dev-perl/XML-Entities/XML-Entities-1.0.200-r1.ebuild
new file mode 100644
index 000000000000..3e516f6e9829
--- /dev/null
+++ b/dev-perl/XML-Entities/XML-Entities-1.0.200-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SIXTEASE
+DIST_VERSION=1.0002
+inherit perl-module
+
+DESCRIPTION="Decode strings with XML entities"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="virtual/perl-Carp
+ !minimal? (
+ dev-perl/HTML-Parser
+ )
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( virtual/perl-Test-Simple )
+"
+
+S="${WORKDIR}/${PN}" # Upstream doesn't tar it up with version in dir
+
+PERL_RM_FILES=("bin/download-entities.pl") # maintainer tool