summaryrefslogtreecommitdiff
path: root/dev-perl/XML-Compile-SOAP/XML-Compile-SOAP-3.240.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/XML-Compile-SOAP/XML-Compile-SOAP-3.240.0-r1.ebuild')
-rw-r--r--dev-perl/XML-Compile-SOAP/XML-Compile-SOAP-3.240.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile-SOAP/XML-Compile-SOAP-3.240.0-r1.ebuild b/dev-perl/XML-Compile-SOAP/XML-Compile-SOAP-3.240.0-r1.ebuild
new file mode 100644
index 000000000000..9dac7b577f1b
--- /dev/null
+++ b/dev-perl/XML-Compile-SOAP/XML-Compile-SOAP-3.240.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=3.24
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Soap 1.1 XML Compiler"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/File-Slurp-Tiny
+ >=dev-perl/libwww-perl-6.80.0
+ >=dev-perl/Log-Report-1.50.0
+ >=dev-perl/Net-HTTP-6.160.0
+ virtual/perl-Time-HiRes
+ >=dev-perl/XML-Compile-1.580.0
+ >=dev-perl/XML-Compile-Cache-1.30.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"