summaryrefslogtreecommitdiff
path: root/dev-perl/Weather-Com/Weather-Com-2.0.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Weather-Com/Weather-Com-2.0.0-r2.ebuild')
-rw-r--r--dev-perl/Weather-Com/Weather-Com-2.0.0-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Weather-Com/Weather-Com-2.0.0-r2.ebuild b/dev-perl/Weather-Com/Weather-Com-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..222d314a0394
--- /dev/null
+++ b/dev-perl/Weather-Com/Weather-Com-2.0.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BOBERNST
+DIST_VERSION=2.0.0
+DIST_EXAMPLES=("samples/*")
+inherit perl-module
+
+DESCRIPTION='fetching weather information from weather.com'
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ dev-perl/HTTP-Message
+ dev-perl/libwww-perl
+ virtual/perl-Locale-Maketext
+ virtual/perl-Storable
+ dev-perl/Test-MockObject
+ >=dev-perl/Time-Format-1.0.0
+ virtual/perl-Time-Local
+ dev-perl/URI
+ dev-perl/XML-Simple
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-dotinc.patch"
+ "${FILESDIR}/${PN}-2.0.0-network.patch"
+)