summaryrefslogtreecommitdiff
path: root/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/WWW-Curl/WWW-Curl-4.170.0-r2.ebuild')
-rw-r--r--dev-perl/WWW-Curl/WWW-Curl-4.170.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r2.ebuild b/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r2.ebuild
new file mode 100644
index 000000000000..42634bc468d1
--- /dev/null
+++ b/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SZBALINT
+DIST_VERSION=4.17
+inherit perl-module
+
+DESCRIPTION="Perl extension interface for libcurl"
+
+LICENSE="|| ( MPL-1.0 MPL-1.1 MIT )"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.150.0-curl-7.50.2.patch
+ "${FILESDIR}"/${PN}-4.17-dotinc.patch
+ "${FILESDIR}"/${PN}-4.17-networktests.patch
+ "${FILESDIR}"/${PN}-4.17-RT117793.patch
+ "${FILESDIR}"/${PN}-4.17-RT130591.patch
+ "${FILESDIR}"/${PN}-4.17-RT132197.patch
+)
+
+PERL_RM_FILES=("t/meta.t" "t/pod-coverage.t" "t/pod.t")