summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild')
-rw-r--r--dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild b/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild
new file mode 100644
index 000000000000..4e755f481fef
--- /dev/null
+++ b/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ABIGAIL
+DIST_VERSION=2017040101
+inherit perl-module
+
+DESCRIPTION="Provide commonly requested regular expressions"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/perl-Test-Simple
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ test? ( >=virtual/perl-Test-Simple-1.1.14 )
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ # Omit code coverage / documentation tests
+ perl_rm_files t/{950,960,980,981,982}*.t
+
+ perl-module_src_test
+}