summaryrefslogtreecommitdiff
path: root/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-MockRandom/Test-MockRandom-1.10.0-r1.ebuild')
-rw-r--r--dev-perl/Test-MockRandom/Test-MockRandom-1.10.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0-r1.ebuild b/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..3f47477cef0d
--- /dev/null
+++ b/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=1.01
+DIST_EXAMPLES=( 'examples/*' )
+inherit perl-module
+
+DESCRIPTION="Replaces random number generation with non-random number generation"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ !minimal? (
+ virtual/perl-CPAN-Meta
+ >=virtual/perl-CPAN-Meta-Requirements-2.120.900
+ )
+ virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple
+ virtual/perl-version
+ )
+"