summaryrefslogtreecommitdiff
path: root/dev-perl/Test-MockObject/Test-MockObject-1.202.1.220.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-MockObject/Test-MockObject-1.202.1.220.ebuild')
-rw-r--r--dev-perl/Test-MockObject/Test-MockObject-1.202.1.220.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Test-MockObject/Test-MockObject-1.202.1.220.ebuild b/dev-perl/Test-MockObject/Test-MockObject-1.202.1.220.ebuild
new file mode 100644
index 000000000000..c00d4d2a3601
--- /dev/null
+++ b/dev-perl/Test-MockObject/Test-MockObject-1.202.1.220.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CHROMATIC
+DIST_VERSION=1.20200122
+inherit perl-module
+
+DESCRIPTION="Perl extension for emulating troublesome interfaces"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/UNIVERSAL-can-1.201.106.170
+ >=dev-perl/UNIVERSAL-isa-1.201.106.140
+ virtual/perl-Test-Simple
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Exception-0.310.0
+ >=virtual/perl-Test-Simple-0.980.0
+ >=dev-perl/Test-Warn-0.230.0
+ )
+"