summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0-r1.ebuild')
-rw-r--r--dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0-r1.ebuild b/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0-r1.ebuild
new file mode 100644
index 000000000000..9ec303342dcd
--- /dev/null
+++ b/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TADAM
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Mocks LWP::UserAgent and dispatches your requests/responses"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ dev-perl/HTTP-Message
+ dev-perl/libwww-perl
+ dev-perl/Test-MockObject
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Exception
+ )
+"
+
+src_test() {
+ perl_rm_files t/release-pod-coverage.t t/release-pod-syntax.t
+ perl-module_src_test
+}