summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Fatal/Test-Fatal-0.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Fatal/Test-Fatal-0.16.0.ebuild')
-rw-r--r--dev-perl/Test-Fatal/Test-Fatal-0.16.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Test-Fatal/Test-Fatal-0.16.0.ebuild b/dev-perl/Test-Fatal/Test-Fatal-0.16.0.ebuild
new file mode 100644
index 000000000000..4af58e90ed7b
--- /dev/null
+++ b/dev-perl/Test-Fatal/Test-Fatal-0.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.016
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Incredibly simple helpers for testing code with exceptions"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-Test-Simple
+ >=dev-perl/Try-Tiny-0.70.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"