summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild')
-rw-r--r--dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild b/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild
new file mode 100644
index 000000000000..80add0a69915
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/Devel-CheckOS
+ )
+ >=virtual/perl-Exporter-5.680.0
+ dev-perl/UNIVERSAL-require
+ >=virtual/perl-parent-0.225.0
+ virtual/perl-version
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)