summaryrefslogtreecommitdiff
path: root/dev-perl/Sereal-Encoder/Sereal-Encoder-4.18.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Sereal-Encoder/Sereal-Encoder-4.18.0.ebuild')
-rw-r--r--dev-perl/Sereal-Encoder/Sereal-Encoder-4.18.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Sereal-Encoder/Sereal-Encoder-4.18.0.ebuild b/dev-perl/Sereal-Encoder/Sereal-Encoder-4.18.0.ebuild
new file mode 100644
index 000000000000..507c4621c161
--- /dev/null
+++ b/dev-perl/Sereal-Encoder/Sereal-Encoder-4.18.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=YVES
+DIST_VERSION=4.018
+inherit perl-module
+
+DESCRIPTION="Fast, compact, powerful binary serialization"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Note: bundled zstd fails compile
+RDEPEND="
+ virtual/perl-XSLoader
+ app-arch/zstd:=
+"
+
+# Tester note: ideally you want dev-perl/Sereal-Decoder
+# as well, but we can't depend on it because it forms
+# a tight cycle if we do
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-7.0.0
+ >=virtual/perl-ExtUtils-ParseXS-2.210.0
+ virtual/perl-File-Path
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Test-Deep
+ dev-perl/Test-Differences
+ dev-perl/Test-LongString
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warn
+ )
+"