summaryrefslogtreecommitdiff
path: root/dev-perl/Regexp-Common-net-CIDR/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Regexp-Common-net-CIDR/files')
-rw-r--r--dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch43
-rw-r--r--dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch23
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch
new file mode 100644
index 000000000000..19d6c031cfe4
--- /dev/null
+++ b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch
@@ -0,0 +1,43 @@
+From 85dd6c8d78ab332921c109d9a8e8577d39502b7c Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 3 Jan 2018 23:24:42 +1300
+Subject: Add basic load and match test
+
+---
+ MANIFEST | 1 +
+ t/basic.t | 14 ++++++++++++++
+ 2 files changed, 15 insertions(+)
+ create mode 100644 t/basic.t
+
+diff --git a/MANIFEST b/MANIFEST
+index 9f7ef84..b5de94a 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -14,3 +14,4 @@ Makefile.PL
+ MANIFEST This list of files
+ META.yml
+ README
++t/basic.t
+diff --git a/t/basic.t b/t/basic.t
+new file mode 100644
+index 0000000..48c2487
+--- /dev/null
++++ b/t/basic.t
+@@ -0,0 +1,14 @@
++
++use strict;
++use warnings;
++
++use Test::More;
++use Regexp::Common;
++use Regexp::Common::net::CIDR;
++
++ok( "1.2.3.4/1" =~ /$RE{net}{CIDR}{IPv4}/, "1.2.3.4/1 is a CIDR");
++ok( "1.2.3.4" !~ /$RE{net}{CIDR}{IPv4}/, "1.2.3.4 is not a CIDR");
++
++done_testing;
++
++
+--
+2.15.1
+
diff --git a/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch
new file mode 100644
index 000000000000..cdd16b7e56ed
--- /dev/null
+++ b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch
@@ -0,0 +1,23 @@
+From 7edb7171dc09e2cb6157724ebeaa45eeb07d8d4b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Tue, 4 Jul 2017 09:19:37 +1200
+Subject: Add build fix for Perl 5.26
+
+Bug: https://bugs.gentoo.org/623090
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 422966a..fea6408 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,4 +1,4 @@
+-use inc::Module::Install;
++use lib q[.]; use inc::Module::Install;
+ name('Regexp-Common-net-CIDR');
+ version_from('lib/Regexp/Common/net/CIDR.pm');
+ license('perl');
+--
+2.15.1
+