summaryrefslogtreecommitdiff
path: root/dev-perl/Quota/Quota-1.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Quota/Quota-1.8.1.ebuild')
-rw-r--r--dev-perl/Quota/Quota-1.8.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Quota/Quota-1.8.1.ebuild b/dev-perl/Quota/Quota-1.8.1.ebuild
new file mode 100644
index 000000000000..7b2014f2a3ea
--- /dev/null
+++ b/dev-perl/Quota/Quota-1.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOMZO
+inherit perl-module toolchain-funcs flag-o-matic
+
+DESCRIPTION="Perl interface to file system quotas"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ sys-fs/quota[rpc]
+ net-libs/libtirpc
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+"
+
+# Tests need real FS access/root permissions and are interactive
+DIST_TEST=skip
+
+src_prepare() {
+ default
+ DIST_MAKE=(
+ "INC=$($(tc-getPKG_CONFIG) --cflags libtirpc)"
+ "OTHERLDFLAGS=$($(tc-getPKG_CONFIG) --libs libtirpc)"
+ )
+
+ # disable AFS completely for now, need somebody who can really test it
+ sed -i -e 's|-d "/afs"|0|' Makefile.PL || die "sed failed"
+}
+
+src_test() {
+ ebegin "Compile testing Quota ${PV}"
+ perl -Mblib="${S}" -M"Quota ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Quota ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}