summaryrefslogtreecommitdiff
path: root/dev-perl/Proc-Guard/Proc-Guard-0.70.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Proc-Guard/Proc-Guard-0.70.0-r1.ebuild')
-rw-r--r--dev-perl/Proc-Guard/Proc-Guard-0.70.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Proc-Guard/Proc-Guard-0.70.0-r1.ebuild b/dev-perl/Proc-Guard/Proc-Guard-0.70.0-r1.ebuild
new file mode 100644
index 000000000000..2d5d4446f5da
--- /dev/null
+++ b/dev-perl/Proc-Guard/Proc-Guard-0.70.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOKUHIROM
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="process runner with RAII pattern"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-perl/Class-Accessor-Lite-0.50.0
+ >=virtual/perl-Exporter-5.630.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/File-Which
+ dev-perl/Test-TCP
+ dev-perl/Test-Requires
+ dev-perl/Test-SharedFork
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"