summaryrefslogtreecommitdiff
path: root/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild')
-rw-r--r--dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild b/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild
new file mode 100644
index 000000000000..b6a7c4e84cc5
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DORMANDO
+MODULE_VERSION=1.80
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://www.danga.com/perlbal/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/libwww-perl
+ dev-perl/HTTP-Date
+ dev-perl/Sys-Syscall
+ >=dev-perl/Danga-Socket-1.440.0
+ dev-perl/HTTP-Message
+ dev-perl/BSD-Resource
+ dev-perl/IO-AIO
+"
+DEPEND="${RDEPEND}"
+
+#SRC_TEST="do" # testing not available on Perlbal yet ;-)
+
+PATCHES=( "${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch" )
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd "${FILESDIR}"/perlbal_init.d_1.58 perlbal
+ newconfd "${FILESDIR}"/perlbal_conf.d_1.58 perlbal
+}
+
+pkg_postinst() {
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}