summaryrefslogtreecommitdiff
path: root/dev-perl/Perl-Tidy/Perl-Tidy-20210717.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20210717.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20210717.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20210717.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20210717.0.0.ebuild
new file mode 100644
index 000000000000..75a5c85ba9ea
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20210717.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20210717
+DIST_EXAMPLES=( "examples/*" )
+
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ https://metacpan.org/release/Perl-Tidy"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=""
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing html is bad
+ docompress -x /usr/share/doc/${PF}/stylekey.html
+ docompress -x /usr/share/doc/${PF}/tutorial.html
+ docompress -x /usr/share/doc/${PF}/perltidy.html
+
+ dodoc docs/stylekey.html
+ dodoc docs/tutorial.html
+ dodoc docs/perltidy.html
+}