summaryrefslogtreecommitdiff
path: root/dev-perl/PPIx-QuoteLike/PPIx-QuoteLike-0.23.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PPIx-QuoteLike/PPIx-QuoteLike-0.23.0.ebuild')
-rw-r--r--dev-perl/PPIx-QuoteLike/PPIx-QuoteLike-0.23.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/PPIx-QuoteLike/PPIx-QuoteLike-0.23.0.ebuild b/dev-perl/PPIx-QuoteLike/PPIx-QuoteLike-0.23.0.ebuild
new file mode 100644
index 000000000000..1dcb32bd3304
--- /dev/null
+++ b/dev-perl/PPIx-QuoteLike/PPIx-QuoteLike-0.23.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=WYANT
+DIST_VERSION=0.023
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Parse Perl string literals and string-literal-like things"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/PPI-1.238.0
+ dev-perl/PPIx-Regexp
+ dev-perl/Readonly
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"