summaryrefslogtreecommitdiff
path: root/dev-perl/PPI/PPI-1.270.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PPI/PPI-1.270.0-r1.ebuild')
-rw-r--r--dev-perl/PPI/PPI-1.270.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/PPI/PPI-1.270.0-r1.ebuild b/dev-perl/PPI/PPI-1.270.0-r1.ebuild
new file mode 100644
index 000000000000..7c9023d4ce56
--- /dev/null
+++ b/dev-perl/PPI/PPI-1.270.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MITHALDU
+DIST_VERSION=1.270
+inherit perl-module
+
+DESCRIPTION="Parse, Analyze and Manipulate Perl (without perl)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ppc ~ppc64 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Clone-0.300.0
+ >=virtual/perl-Digest-MD5-2.350.0
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ >=dev-perl/IO-String-1.70.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=dev-perl/Params-Util-1.000.0
+ >=virtual/perl-Storable-2.170.0
+ dev-perl/Task-Weaken
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Class-Inspector-1.220.0
+ virtual/perl-Encode
+ >=dev-perl/File-Remove-1.420.0
+ virtual/perl-File-Temp
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-NoWarnings
+ >=dev-perl/Test-Object-0.70.0
+ >=dev-perl/Test-SubCalls-1.70.0
+ )
+"