summaryrefslogtreecommitdiff
path: root/dev-perl/Number-WithError
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Number-WithError')
-rw-r--r--dev-perl/Number-WithError/Manifest4
-rw-r--r--dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild33
-rw-r--r--dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch24
-rw-r--r--dev-perl/Number-WithError/metadata.xml12
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/Number-WithError/Manifest b/dev-perl/Number-WithError/Manifest
new file mode 100644
index 000000000000..56c0a61c3ce6
--- /dev/null
+++ b/dev-perl/Number-WithError/Manifest
@@ -0,0 +1,4 @@
+AUX Number-WithError-1.01-no-dot-inc.patch 598 BLAKE2B 94f1b4bbafb1fac596dcbac134114d7bdfd75ba9764f28dc38d3a3edf662f1aa241af74e6be3397548866cd619ef2b8ab9cf76db40ef99a1c4315543e8b3ff9f SHA512 37b0d3307084ab71d4cfd22dfd9e57ff4b1e104ec70c89cd6794fa1502c5f074487944876b50b738aa171afac9c9a7d9a1e328bfcd66b751e1c355d8a7da93db
+DIST Number-WithError-1.01.tar.gz 38949 BLAKE2B 5ec7588f881bd46d329456c56a9b20455ec6d074e6f7531f9a039a7a9af5f121d21d17d9ea7b6bc2db42de2040961bd72d748ffab077816b62b5d9b8e910aaf7 SHA512 8d573801fa6c82b1e1578035f34d3208abc11cdd300563b21ae5a1f229f651e9f0b3f3c277da632ce3f583b86e99918ac0b5498ad3727a19e4d100b7e00df93b
+EBUILD Number-WithError-1.10.0.ebuild 651 BLAKE2B 894ba577a98804120e84aaec206848b9c36eae17c45b36763f1898a553b938eb869b1eb9e3a9604fcf8b7b6c0db7fcbd61df19a7bb510ab78cada0ac187d9f88 SHA512 264392a2c57092a42bc6452aaf290f1a4dc86e8374a7893a51aa2285b9d7998949a40d5f35e90c7a246912f6b26a2c2e264e374eaa031839023c69c49f9e0aec
+MISC metadata.xml 404 BLAKE2B 79a5c1671975be8327dd6aa96ec6f4ec6c84ad11d95ebd00bab2bcebab3499ed833782e11d0b9d8aa05fac99ccb77e3165e7eebc86bf50c25f633be4d17aa381 SHA512 ebb4fe68ab68ea5f68cc4a549a887db0715a46fe55cab3c1c796ce81dcdc40d23543439b611e1a75cc270c7525635dea3a15cc721fbecf75cbc47fede3ad2a88
diff --git a/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild b/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
new file mode 100644
index 000000000000..f33ff808f67d
--- /dev/null
+++ b/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SMUELLER
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Numbers with error propagation and scientific rounding"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.400.0
+ >=dev-perl/Params-Util-0.100.0
+ >=dev-perl/prefork-1.0.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Test-LectroTest
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/00podcover.t"
+ "t/00pod.t"
+)
diff --git a/dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch b/dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch
new file mode 100644
index 000000000000..62c40029cdcf
--- /dev/null
+++ b/dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch
@@ -0,0 +1,24 @@
+From 8c15ff58866e38cb8ce4f7b7ad3ecac941f5863d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 7 Sep 2018 20:23:23 +1200
+Subject: Fix Makefile.PL to work on perl 5.26+/no-dot-inc perls
+
+Perl 5.26+ have @INC without '.' unless PERL_USE_UNSAFE_INC=1
+
+Perl 5.30+ will have no hack to avoid this problem \o/
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 76b23e1..a3c10b1 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Number-WithError';
+--
+2.17.1
+
diff --git a/dev-perl/Number-WithError/metadata.xml b/dev-perl/Number-WithError/metadata.xml
new file mode 100644
index 000000000000..91fdeb8c1632
--- /dev/null
+++ b/dev-perl/Number-WithError/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Number-WithError</remote-id>
+ <remote-id type="cpan-module">Number::WithError</remote-id>
+ </upstream>
+</pkgmetadata>