summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0-r1.ebuild')
-rw-r--r--dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0-r1.ebuild b/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0-r1.ebuild
new file mode 100644
index 000000000000..a20fe4700c8d
--- /dev/null
+++ b/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=KRYDE
+DIST_VERSION=0.40
+inherit perl-module
+
+DESCRIPTION="Factorize numbers and calculate matching multiplications"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="
+ dev-perl/boolean
+ dev-perl/List-MoreUtils
+ dev-perl/Params-Validate
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ virtual/perl-ExtUtils-CBuilder
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_test() {
+ perl_rm_files "t/pod.t" "t/pod-coverage.t"
+ perl-module_src_test
+}