summaryrefslogtreecommitdiff
path: root/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild')
-rw-r--r--dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild b/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
deleted file mode 100644
index 6755e1b59465..000000000000
--- a/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=NEILB
-DIST_VERSION=0.80
-inherit perl-module
-
-DESCRIPTION="Simple platform independent mailer"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="
- virtual/perl-Digest-MD5
- virtual/perl-Exporter
- virtual/perl-MIME-Base64
- virtual/perl-Socket
- virtual/perl-Time-Local
- virtual/perl-parent
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-src_test() {
- local MODULES=(
- "Mail::Sendmail ${DIST_VERSION}"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
- if has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
- perl-module_src_test
- else
- ewarn "Network tests disabled without DIST_TEST_OVERRIDE=~network"
- fi
-}