summaryrefslogtreecommitdiff
path: root/dev-perl/Mail-Sender/Mail-Sender-0.903.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Mail-Sender/Mail-Sender-0.903.0-r1.ebuild')
-rw-r--r--dev-perl/Mail-Sender/Mail-Sender-0.903.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Mail-Sender/Mail-Sender-0.903.0-r1.ebuild b/dev-perl/Mail-Sender/Mail-Sender-0.903.0-r1.ebuild
new file mode 100644
index 000000000000..566ca750a4af
--- /dev/null
+++ b/dev-perl/Mail-Sender/Mail-Sender-0.903.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CAPOEIRAB
+DIST_VERSION=0.903
+inherit perl-module
+
+DESCRIPTION="Module for sending mails with attachments through an SMTP server"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="minimal"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/Authen-NTLM
+ dev-perl/Digest-HMAC
+ dev-perl/IO-Socket-SSL
+ dev-perl/Mozilla-CA
+ dev-perl/Net-SSLeay
+ )
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ virtual/perl-IO
+ virtual/perl-MIME-Base64
+ virtual/perl-Socket
+ virtual/perl-Time-Local
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+pkg_postinst() {
+ ewarn "dev-perl/Mail-Sender is deprecated by upstream."
+ ewarn
+ ewarn "You should consider moving away from it and use"
+ ewarn "dev-perl/Email-Sender instead"
+}