summaryrefslogtreecommitdiff
path: root/dev-perl/Mail-IMAPClient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Mail-IMAPClient')
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.430.0.ebuild50
-rw-r--r--dev-perl/Mail-IMAPClient/Manifest3
-rw-r--r--dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch89
3 files changed, 142 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.430.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.430.0.ebuild
new file mode 100644
index 000000000000..838701d57b8f
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.430.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PLOBBES
+DIST_VERSION=3.43
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test ntlm md5 ssl zlib"
+
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+
+PERL_RM_FILES=(
+ "t/quota.t" # Requires imap server config in test.txt
+ "t/basic.t"
+ "t/pod.t" # Bad author test
+)
+
+# IO::File, IO::Select, IO::Socket, IO::Socket::INET -> perl-IO
+# Digest::HMAC_MD5 -> Digest-HMAC
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=virtual/perl-IO-1.260.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.940.0
+ ntlm? ( dev-perl/Authen-NTLM )
+ md5? (
+ dev-perl/Authen-SASL
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ zlib? ( virtual/perl-IO-Compress )
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Mail-IMAPClient/Manifest b/dev-perl/Mail-IMAPClient/Manifest
index 6490448c9c13..818eca8712f5 100644
--- a/dev-perl/Mail-IMAPClient/Manifest
+++ b/dev-perl/Mail-IMAPClient/Manifest
@@ -1,4 +1,7 @@
AUX 3.39-makefilepl.patch 2592 BLAKE2B f19b22a6f32c6acb1cdfd2bbf7f6a14d1d4b360933c5832e949be73e21167b3eb814078466722ee35fb582271b46e0c0b65125ee16e3a1fa73bd8962fc346789 SHA512 007dd94afc738de520317275c940569bc4bb95b4a70eb8e0699c59c23a9e58d2bd68f5ae73ceeb7b7e9b84cf1f61f1e28ed0f05a20eff89191589b9342d443d1
+AUX 3.43-makefilepl.patch 2676 BLAKE2B feb527eb527a9d678ce8b14672b5dd1d686221289b3c0ddfe33c329a15de20c3e6b53c389d07e74c90850221bf5b619242134e2b96b052ca5b1dbeef92244959 SHA512 98d1740ab709e4f1d7ff467d9f0ed8d4d381f9a1a2e2bfb4b957a87c6c6bda3a273b12f61bc55f2f76b008ceee39fcc0a363dca72f943191e8878aefd9bee33b
DIST Mail-IMAPClient-3.39.tar.gz 190965 BLAKE2B 43fb640d2282945b21e743ccb8bec037103b7bcff78396f1f72f26d7860d5b5f69bcab837f3e857610426f958c860085f66cef21c8d5115940fc64ae3667f1e3 SHA512 156e5f6682d55f2c112ae5065448f0c502d3e748c4405768152ccccd7d944cf949f7c3fd42f30f40c86337457dea5c037959bf29739e4c413e4b45af2b74c222
+DIST Mail-IMAPClient-3.43.tar.gz 189679 BLAKE2B da28ec4358532dcac59241dca4ffc29c3cf86bc3bba388dd66e27f45ac675c4754d0def00eb7112e4b1ffb1d595b3941b160a3f3e81a8ffccacc8351b4f96a94 SHA512 9e2346238d68ea62c0ad2e5c03ae9a36face8238dbccbbc083bcefd41d82a7f75887e3245c792e4bd2a5999ce66fabdc4e861118904e96cf2781e1ca549a1b09
EBUILD Mail-IMAPClient-3.390.0.ebuild 1106 BLAKE2B 33c0d3d1b1d942be2e00227ced4c421d404dd6abfc6cb50012683f460ae354837e4163ebda21d38b40389b2ac81213fae39c401839022676075028ba13568813 SHA512 a8e2329509b804fba694ffd3359047314618a7d91d4f0ca245aa3e970ca9735ee5ff3d49604024ee7313773050625637ca7dbecac99e71879cc9892713241c80
+EBUILD Mail-IMAPClient-3.430.0.ebuild 1089 BLAKE2B d855897ac2d2c2136c695101e5a15a42cb6779f0eeab2db572def989d1980422da48e28f8097064754a2512e1b6dcc7ce3544b3c14f57f2ba0a22bf4874a573c SHA512 869e57a09b01ce69e0505dba4dd1d639d96a20889d3234e6a26c492249f86f6f3c984d1d6c8e58a6b53cb1e6fac9a106a52a6f081231fa2bf5d763a221b17505
MISC metadata.xml 1479 BLAKE2B c6dd142a9311a0e0d425ef22933e04327f24d53cb41d8428d14de58806be9a55be319382e1f07bf445c8f35d83842d915ad7cacbfc47621f957a8484985369e1 SHA512 9ab467eb24b4805b0b505cc0a4c950206281d65ea4868d2aa759c94457e1bb8a382ee7ac84627392f3e3416056da7e1aa87f0de810c1d9fc63d39628040ecddf
diff --git a/dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch b/dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch
new file mode 100644
index 000000000000..35990fe79c7e
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch
@@ -0,0 +1,89 @@
+diff -ruN Mail-IMAPClient-3.43.orig/Makefile.PL Mail-IMAPClient-3.43/Makefile.PL
+--- Mail-IMAPClient-3.43.orig/Makefile.PL 2021-02-16 17:47:10.000000000 +0100
++++ Mail-IMAPClient-3.43/Makefile.PL 2021-06-28 22:55:47.886460876 +0200
+@@ -4,39 +4,6 @@
+
+ use 5.008_001;
+
+-my @missing;
+-my %optional = (
+- "Authen::NTLM" => { for => "Authmechanism 'NTLM'" },
+- "Authen::SASL" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "Compress::Zlib" => { for => "COMPRESS DEFLATE support" },
+- "Digest::HMAC_MD5" => { for => "Authmechanism 'CRAM-MD5'" },
+- "Digest::MD5" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "IO::Socket::IP" => { for => "IPv6 support" },
+- "IO::Socket::SSL" => { for => "SSL enabled connections (Ssl => 1)" },
+- "Test::Pod" => { for => "Pod tests", ver => "1.00" },
+-);
+-
+-foreach my $mod ( sort keys %optional ) {
+- my $for = $optional{$mod}->{"for"} || "";
+- my $ver = $optional{$mod}->{"ver"} || "";
+- eval "use $mod $ver ();";
+- push @missing, $mod . ( $for ? " for $for" : "" ) if $@;
+-}
+-
+-# similar message to one used in DBI:
+-if (@missing) {
+- print( "The following optional modules were not found:",
+- map( "\n\t" . $_, @missing ), "\n" );
+-
+- print <<'MSG';
+-Optional modules are available from any CPAN mirror, reference:
+- https://metacpan.org/
+- https://www.cpan.org/modules/by-module/
+-
+-MSG
+- sleep 3;
+-}
+-
+ # HACK: die on broken Parse::RecDescent 1.966002 through 1.967009
+ # - rt.cpan.org#74593: Recent changes break Module::ExtractUse and ...
+ # - rt.cpan.org#74733: Fails with Parse::RecDescent >= 1.966_002
+@@ -92,45 +59,5 @@
+ clean => { FILES => 'test.txt' },
+ );
+
+-set_test_data();
+-
+ exit 0;
+
+-###
+-### HELPERS
+-###
+-
+-sub set_test_data {
+- unless ( -f "lib/Mail/IMAPClient.pm" ) {
+- warn("ERROR: not in installation directory\n");
+- return;
+- }
+-
+- if ( -s "./test.txt" ) {
+- print("The file test.txt will be used for extended tests.\n");
+- return;
+- }
+-
+- print <<EOF;
+-
+-(OPTIONAL) For extended tests during 'make test', create a file
+-'test.txt' in the top level directory of this distribution (the same
+-directory as the Makefile.PL, etc.). This file must contain an IMAP
+-server name or IP (server=...), a user account (user=...), and a
+-password (passed=...). A port (port=....) and an authentication
+-mechanism to be used (authmechanism=...) can also be specified.
+-
+-Example:
+-
+---- BEGIN: test.txt ---
+-server=localhost
+-user=mytestuser
+-passed=mypassword
+-port=143
+---- END: test.txt ---
+-
+-NOTE: When testing is completed, be sure to remove test.txt (either by
+-hand or by 'make clean').
+-
+-EOF
+-}