summaryrefslogtreecommitdiff
path: root/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r2.ebuild')
-rw-r--r--dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r2.ebuild b/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r2.ebuild
new file mode 100644
index 000000000000..a986c052bfd4
--- /dev/null
+++ b/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CINE
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Porters stemming algorithm for Denmark"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc sparc x86"
+
+src_install() {
+ perl-module_src_install
+
+ if [[ -f ${D}/${VENDOR_LIB}/Lingua/Stem/Snowball/stemmer.pl ]] ; then
+ mv "${D}"/${VENDOR_LIB}/Lingua/Stem/Snowball/{,da-}stemmer.pl || die
+ fi
+}
+
+pkg_postinst() {
+ elog "The stemmer.pl that ships with this distribution has been renamed to"
+ elog "da-stemmer.pl to avoid collisions with other Lingua::Stem packages."
+}