summaryrefslogtreecommitdiff
path: root/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0-r1.ebuild')
-rw-r--r--dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0-r1.ebuild b/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0-r1.ebuild
new file mode 100644
index 000000000000..bcb624c0a29e
--- /dev/null
+++ b/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RCAPUTO
+DIST_VERSION=1.023
+inherit perl-module
+
+DESCRIPTION="Bind lexicals to persistent data"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ >=dev-perl/PadWalker-1.960.0
+ >=dev-perl/Devel-LexAlias-0.50.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Carp-1.260.0
+ >=virtual/perl-Scalar-List-Utils-1.290.0
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+
+PERL_RM_FILES=( "t/02_pod.t" "t/03_pod_coverage.t" "t/release-pod-coverage.t" "t/release-pod-syntax.t" )