summaryrefslogtreecommitdiff
path: root/dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild')
-rw-r--r--dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild b/dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild
index 28b084b4d8ca..c8bbd939b644 100644
--- a/dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild
+++ b/dev-perl/Lab-Zhinst/Lab-Zhinst-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
if [[ "${PV}" != "9999" ]]; then
- DIST_VERSION=xxxxxx # change this when released
+ # DIST_VERSION=2.04
DIST_AUTHOR=AMBA
inherit perl-module
+
KEYWORDS="~amd64"
else
EGIT_REPO_URI="https://github.com/lab-measurement/Lab-Zhinst.git"
@@ -15,12 +16,19 @@ else
fi
DESCRIPTION="Perl bindings to the LabOne API of Zurich Instruments"
-HOMEPAGE="http://search.cpan.org/~amba/Lab-Zhinst/"
SLOT="0"
-IUSE=""
-RDEPEND="sci-electronics/labone"
-DEPEND="${RDEPEND}
+RDEPEND="
+ virtual/perl-AutoLoader
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+ sci-electronics/labone
+"
+DEPEND="
+ sci-electronics/labone
+"
+BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"