summaryrefslogtreecommitdiff
path: root/dev-perl/LWP-Authen-Wsse/LWP-Authen-Wsse-0.50.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/LWP-Authen-Wsse/LWP-Authen-Wsse-0.50.0-r2.ebuild')
-rw-r--r--dev-perl/LWP-Authen-Wsse/LWP-Authen-Wsse-0.50.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/LWP-Authen-Wsse/LWP-Authen-Wsse-0.50.0-r2.ebuild b/dev-perl/LWP-Authen-Wsse/LWP-Authen-Wsse-0.50.0-r2.ebuild
new file mode 100644
index 000000000000..0e17a61d2f66
--- /dev/null
+++ b/dev-perl/LWP-Authen-Wsse/LWP-Authen-Wsse-0.50.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=AUTRIJUS
+DIST_VERSION=0.05
+inherit perl-module
+
+DESCRIPTION="Library for enabling X-WSSE authentication in LWP"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ virtual/perl-MIME-Base64
+ dev-perl/Digest-SHA1
+"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}