summaryrefslogtreecommitdiff
path: root/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
new file mode 100644
index 000000000000..575cfddc122f
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.56
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.460.0
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Proc-ProcessTable-0.530.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Deep
+ dev-perl/Test-Number-Delta
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )