summaryrefslogtreecommitdiff
path: root/dev-perl/IPC-Shareable/IPC-Shareable-1.60.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/IPC-Shareable/IPC-Shareable-1.60.0.ebuild')
-rw-r--r--dev-perl/IPC-Shareable/IPC-Shareable-1.60.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/IPC-Shareable/IPC-Shareable-1.60.0.ebuild b/dev-perl/IPC-Shareable/IPC-Shareable-1.60.0.ebuild
new file mode 100644
index 000000000000..375c7edc8958
--- /dev/null
+++ b/dev-perl/IPC-Shareable/IPC-Shareable-1.60.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=STEVEB
+DIST_VERSION=1.06
+inherit perl-module
+
+DESCRIPTION="Share Perl variables between processes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/JSON
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-0.607.0
+ dev-perl/String-CRC32
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.720.0
+ test? (
+ >=dev-perl/Test-SharedFork-0.350.0
+ virtual/perl-Test-Simple
+ )
+"
+
+# tests fail when running parallelized, see bug 797445
+DIST_TEST=do