summaryrefslogtreecommitdiff
path: root/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild')
-rw-r--r--dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild b/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild
new file mode 100644
index 000000000000..7925730085d0
--- /dev/null
+++ b/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GFUJI
+DIST_VERSION=0.15
+DIST_EXAMPLES=( "example/*" "benchmark" )
+inherit perl-module
+
+DESCRIPTION="Lightweight field hash for inside-out objects"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-XSLoader-0.20.0
+ >=virtual/perl-parent-0.221.0
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-Devel-PPPort-3.190.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-2.210.0
+ >=dev-perl/Module-Build-0.400.500
+ test? (
+ >=dev-perl/Test-LeakTrace-0.70.0
+ >=virtual/perl-Test-Simple-0.620.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15-no-dot-inc.patch"
+)
+src_configure() {
+ unset LD;
+ if [[ -n "${CCLD}" ]]; then
+ export LD="${CCLD}"
+ fi
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}