summaryrefslogtreecommitdiff
path: root/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.952.400.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.952.400.ebuild')
-rw-r--r--dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.952.400.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.952.400.ebuild b/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.952.400.ebuild
new file mode 100644
index 000000000000..4ff38b3128b9
--- /dev/null
+++ b/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.952.400.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=VIY
+DIST_VERSION=0.9524
+inherit perl-module
+
+DESCRIPTION='Perl/XS module to use HTML Templates from CGI scripts'
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/libpcre2
+ >=virtual/perl-File-Path-2.0.0
+ virtual/perl-File-Spec
+ >=dev-perl/JSON-2.0.0"
+DEPEND="dev-libs/libpcre2"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_configure() {
+ local myconf=(
+ "PCRE2=1"
+ )
+
+ perl-module_src_configure "${myconf[@]}"
+}