summaryrefslogtreecommitdiff
path: root/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch')
-rw-r--r--dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch b/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch
new file mode 100644
index 000000000000..5e7f8b6a3efe
--- /dev/null
+++ b/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch
@@ -0,0 +1,16 @@
+We don't want to rely on sys-apps/which and it doesn't serve much purpose
+to do this check at all. We already die if we can't find the gpg version
+on the next line anyway.
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -3,10 +3,6 @@ use strict;
+ use warnings;
+ use inc::Module::Install;
+
+-print "which gpg ... ";
+-system("which", "gpg");
+-die "gpg (GnuPG) not found" if ( $? != 0 );
+-
+ my $output = `gpg --version`;
+ die "Can't determine gpg version"
+ unless $output =~ /^gpg \(GnuPG.*?\) (\d+\.\d+)/;