summaryrefslogtreecommitdiff
path: root/dev-perl/GeoIP2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/GeoIP2')
-rw-r--r--dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild48
-rw-r--r--dev-perl/GeoIP2/Manifest3
-rw-r--r--dev-perl/GeoIP2/metadata.xml51
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild b/dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild
new file mode 100644
index 000000000000..1d22f4beebe4
--- /dev/null
+++ b/dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MAXMIND
+DIST_VERSION=2.006002
+inherit perl-module
+
+DESCRIPTION="API for MaxMind's GeoIP2 web services and databases"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=dev-perl/Data-Validate-IP-0.250.0
+ virtual/perl-Exporter
+ virtual/perl-Getopt-Long
+ dev-perl/HTTP-Message
+ dev-perl/JSON-MaybeXS
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ dev-perl/List-SomeUtils
+ virtual/perl-MIME-Base64
+ >=dev-perl/MaxMind-DB-Reader-1.0.0
+ dev-perl/Moo
+ dev-perl/Params-Validate
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Quote
+ dev-perl/Throwable
+ dev-perl/Try-Tiny
+ dev-perl/URI
+ dev-perl/namespace-clean
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO-Compress
+ dev-perl/MaxMind-DB-Common
+ dev-perl/Path-Class
+ dev-perl/Test-Fatal
+ dev-perl/Test-Number-Delta
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/GeoIP2/Manifest b/dev-perl/GeoIP2/Manifest
new file mode 100644
index 000000000000..046f0a61e3bb
--- /dev/null
+++ b/dev-perl/GeoIP2/Manifest
@@ -0,0 +1,3 @@
+DIST GeoIP2-2.006002.tar.gz 249915 BLAKE2B c1635de576e0c7f0ebad85bb3d850d6fbc979108777c494ec1685b4ce68b87c895e46df904b9cde5712b9d6aa9f6b341b66c024459f6cf88546f2e6ef6732c0f SHA512 a552c6487b340aa928cfc6ce037724cf0fa98332b731388734bc2b25e7d1a31e2c45c0cd12b6c962b5b483172837587254d742fb04cbcec67586d92dae71e356
+EBUILD GeoIP2-2.6.2.ebuild 1046 BLAKE2B aa40e3b353af03f6a528f84e6ed858a2e677ccb8d5060b4812299bbfe145ff37d694ece23554fdb79a9a677b594d08fefee2166b26d8ccac3100cff59d443759 SHA512 5d96ac6289af197b2bfe33c9e151d5a4a361e075ea594d9fb1ea5969f885496dc82f3c8db8165fd4f192cbbbe8b5af65b4940d2e20b6e30709787326a3db8483
+MISC metadata.xml 2989 BLAKE2B 27618fa92f55207e9a545f9a791ac6cdc347dc6a4f26df5277b0c1981963d125e9347a45cf0cc63272e0d87a1074fa5a6f8161d3dc6b94d4128351773a77c1c5 SHA512 ced2873b6dcc53dd28572c82984acee8529fb9e273549e934670b04528f09dc2279f051fe107e293707900295f48a4bca1def60bfb36edca267564d76fde9e1c
diff --git a/dev-perl/GeoIP2/metadata.xml b/dev-perl/GeoIP2/metadata.xml
new file mode 100644
index 000000000000..e3f764df66cb
--- /dev/null
+++ b/dev-perl/GeoIP2/metadata.xml
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">GeoIP2</remote-id>
+ <remote-id type="cpan-module">GeoIP2</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Database::Reader</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Error::Generic</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Error::HTTP</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Error::IPAddressNotFound</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Error::Type</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Error::WebService</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::ASN</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::AnonymousIP</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::City</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::ConnectionType</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::Country</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::Domain</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::Enterprise</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::ISP</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Model::Insights</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::City</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::Continent</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::Country</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::Location</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::MaxMind</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::Postal</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::RepresentedCountry</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::Subdivision</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Record::Traits</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Error::HTTP</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::HasIPAddress</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::HasLocales</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Model</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Model::Flat</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Model::HasSubdivisions</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Model::Location</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Record::Country</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Role::Record::HasNames</remote-id>
+ <remote-id type="cpan-module">GeoIP2::Types</remote-id>
+ <remote-id type="cpan-module">GeoIP2::WebService::Client</remote-id>
+ </upstream>
+</pkgmetadata>