summaryrefslogtreecommitdiff
path: root/dev-perl/ExtUtils-CppGuess
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/ExtUtils-CppGuess')
-rw-r--r--dev-perl/ExtUtils-CppGuess/ExtUtils-CppGuess-0.110.0.ebuild30
-rw-r--r--dev-perl/ExtUtils-CppGuess/Manifest4
-rw-r--r--dev-perl/ExtUtils-CppGuess/files/ExtUtils-CppGuess-0.110.0-no-dot-inc.patch56
-rw-r--r--dev-perl/ExtUtils-CppGuess/metadata.xml12
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-CppGuess/ExtUtils-CppGuess-0.110.0.ebuild b/dev-perl/ExtUtils-CppGuess/ExtUtils-CppGuess-0.110.0.ebuild
new file mode 100644
index 000000000000..2b2c4e634210
--- /dev/null
+++ b/dev-perl/ExtUtils-CppGuess/ExtUtils-CppGuess-0.110.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DAVIDO
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Guess C++ compiler and flags"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Capture-Tiny
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Path
+ virtual/perl-Data-Dumper
+ virtual/perl-ExtUtils-Manifest
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ dev-perl/Module-Build
+ )
+"
+PATCHES=( "${FILESDIR}/${P}-no-dot-inc.patch" )
diff --git a/dev-perl/ExtUtils-CppGuess/Manifest b/dev-perl/ExtUtils-CppGuess/Manifest
new file mode 100644
index 000000000000..2f41b78ea202
--- /dev/null
+++ b/dev-perl/ExtUtils-CppGuess/Manifest
@@ -0,0 +1,4 @@
+AUX ExtUtils-CppGuess-0.110.0-no-dot-inc.patch 1311 BLAKE2B b440f31822cff738807914df48aa74fdc3775d5eaaea1dcbde4a94217d4d98b2402b44914f463f733bd37460b07c8b1bb99f4d3d06a951d8e57517cbc4d67e4f SHA512 b75865b0f95137389d86ac2b277ae843d8f65075784df73a2de4408ccb9614809b9055798a3ead088fcb17884b1306f4238f817f13b012ea7a913a26e6b8e191
+DIST ExtUtils-CppGuess-0.11.tar.gz 6794 BLAKE2B 95372c6ddfabffd72dac9e6a2ab05da1b72f6617f3cb3ed5d63e572c17ad24a225b142df100d052206a103dc0e8d681f19e7ea440cb009b6493093be31f132f2 SHA512 68039779106386efb20cd6e9125d5882e20257f6a1b1f830b32c9f4df70f66a0cf1706f573e4c80159488526656732ede844b37edbf3f1d4a111898eca66fa9e
+EBUILD ExtUtils-CppGuess-0.110.0.ebuild 572 BLAKE2B e1a31684a55b95ab077e8e9cf0fe47ff246ca36133505af225892fd392215a30fa78863f889e98291bfcf0dbe45dfa66bd37d9fccdf5b2654f29db6c57f29631 SHA512 d92d13f20452f6267f1ba068a4c358f39c27df8aa6fa8bd91b21aebd6749281e1de8dfab9c4f3ce6ab5f5d6f8cd92bc952e1882c9ca466e3d14f9d02b576d1d4
+MISC metadata.xml 394 BLAKE2B 1a416cb6a36c2f53deb351df80a6bd1236f1372f49fc9c8229ec7b081d38661f8e80c30eb2be9e17c559e8187a3d84b8a03152149c9ae5d56907c86d5e8b9d20 SHA512 8e17f9bd71bd2c3a7f8fe7f5e4f8ce0692de2f9b5be8b1538d2895c7e9b57a6a18a4dbe334b2a8e24f8d361c71753bb57e59b0a208138ff82663ab9dcbd581f6
diff --git a/dev-perl/ExtUtils-CppGuess/files/ExtUtils-CppGuess-0.110.0-no-dot-inc.patch b/dev-perl/ExtUtils-CppGuess/files/ExtUtils-CppGuess-0.110.0-no-dot-inc.patch
new file mode 100644
index 000000000000..0bca84c1aad7
--- /dev/null
+++ b/dev-perl/ExtUtils-CppGuess/files/ExtUtils-CppGuess-0.110.0-no-dot-inc.patch
@@ -0,0 +1,56 @@
+From 2c89bb54f233776fb8760a264286f9e0932f62c6 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 21 Oct 2017 13:15:43 +1300
+Subject: Fix tests on 5.26 without '.' in @INC
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120848
+Bug: https://bugs.gentoo.org/615842
+Bug: https://github.com/tsee/extutils-cppguess/pull/15
+---
+ t/010_module_build.t | 3 ++-
+ t/011_makemaker.t | 3 ++-
+ t/lib/TestUtils.pm | 3 ++-
+ 3 files changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/t/010_module_build.t b/t/010_module_build.t
+index 93b5f44..ef004d3 100644
+--- a/t/010_module_build.t
++++ b/t/010_module_build.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use Test::More tests => 1;
+-use t::lib::TestUtils;
++use lib 't/lib';
++use TestUtils;
+
+ my $separator = ( '=' x 40 . "\n" );
+
+diff --git a/t/011_makemaker.t b/t/011_makemaker.t
+index 237636a..5986395 100644
+--- a/t/011_makemaker.t
++++ b/t/011_makemaker.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use Test::More tests => 1;
+-use t::lib::TestUtils;
++use lib 't/lib';
++use TestUtils;
+
+ my $separator = ( '=' x 40 . "\n" );
+
+diff --git a/t/lib/TestUtils.pm b/t/lib/TestUtils.pm
+index c71572b..b3480c4 100644
+--- a/t/lib/TestUtils.pm
++++ b/t/lib/TestUtils.pm
+@@ -1,4 +1,5 @@
+-package t::lib::TestUtils;
++package # hide
++ TestUtils;
+
+ use strict;
+
+--
+2.14.2
+
diff --git a/dev-perl/ExtUtils-CppGuess/metadata.xml b/dev-perl/ExtUtils-CppGuess/metadata.xml
new file mode 100644
index 000000000000..297b581c1332
--- /dev/null
+++ b/dev-perl/ExtUtils-CppGuess/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">ExtUtils-CppGuess</remote-id>
+ <remote-id type="cpan-module">ExtUtils::CppGuess</remote-id>
+ </upstream>
+</pkgmetadata>