summaryrefslogtreecommitdiff
path: root/dev-perl/EV/EV-4.330.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/EV/EV-4.330.0.ebuild')
-rw-r--r--dev-perl/EV/EV-4.330.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-perl/EV/EV-4.330.0.ebuild b/dev-perl/EV/EV-4.330.0.ebuild
index ec997f6507ff..374a2b8ab945 100644
--- a/dev-perl/EV/EV-4.330.0.ebuild
+++ b/dev-perl/EV/EV-4.330.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=MLEHMANN
DIST_VERSION=4.33
-inherit perl-module
+inherit flag-o-matic perl-module
DESCRIPTION="Perl interface to libev, a high performance full-featured event loop"
LICENSE=" || ( Artistic GPL-1+ ) || ( BSD-2 GPL-2+ )"
@@ -21,6 +21,10 @@ BDEPEND="${RDEPEND}
dev-perl/Canary-Stability
"
src_compile() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
mymake=(
"OPTIMIZE=${CFLAGS}"
)