summaryrefslogtreecommitdiff
path: root/dev-perl/DBD-Pg
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.10.0.ebuild97
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild110
-rw-r--r--dev-perl/DBD-Pg/Manifest4
3 files changed, 0 insertions, 211 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.10.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.10.0.ebuild
deleted file mode 100644
index f3f290d64920..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.10.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
-
-src_test() {
- local MODULES=(
- # Compile failure: https://rt.cpan.org/Ticket/Display.html?id=123218
- # "Bundle::DBD::Pg v${PV}"
- "DBD::Pg v${PV}"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1 #||
- #die "Could not load ${dep}"
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
-
- local LIVEDB_TESTS=(
- "t/01connect.t"
- "t/02attribs.t"
- "t/03dbmethod.t"
- "t/03smethod.t"
- "t/04misc.t"
- "t/06bytea.t"
- "t/07copy.t"
- "t/08async.t"
- "t/09arrays.t"
- "t/12placeholders.t"
- "t/20savepoints.t"
- "t/30unicode.t"
- )
- local SKIP_TESTS=(
- "t/00_signature.t"
- );
- if [[ ! -v DBI_DSN ]]; then
- ewarn "Functional database tests disabled due to lack of configuration."
- ewarn "Please set the following environment variables values pertaining to a"
- ewarn "pre-configured Postgres installation in order for tests to work:"
- ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
- ewarn " ( eg: dbi:Pg:dbname=testdb )"
- ewarn " DBI_USER - A Postgres Database Username"
- ewarn " DBI_PASS - A Postgres Database Password"
- ewarn ""
- ewarn "For details, visit:"
- ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
- SKIP_TESTS+=( "${LIVEDB_TESTS[@]}" )
- fi
- perl_rm_files "${SKIP_TESTS[@]}"
- # Parallel testing breaks database access
- DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
-
-}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild
deleted file mode 100644
index 2b055bbeddd3..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="
- dev-db/postgresql:*
-"
-BDEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? (
- >=virtual/perl-Test-Simple-0.880.0
- virtual/perl-Time-HiRes
- )
-"
-PERL_RM_FILES=(
- "t/00_signature.t"
-)
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
-
-src_compile() {
- mymake=(
- "OPTIMIZE=${CFLAGS}"
- )
- perl-module_src_compile
-}
-
-src_test() {
- local MODULES=(
- "Bundle::DBD::Pg v${PV}"
- "DBD::Pg v${PV}"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1 #||
- #die "Could not load ${dep}"
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
-
- local LIVEDB_TESTS=(
- "t/01connect.t"
- "t/02attribs.t"
- "t/03dbmethod.t"
- "t/03smethod.t"
- "t/04misc.t"
- "t/06bytea.t"
- "t/07copy.t"
- "t/08async.t"
- "t/09arrays.t"
- "t/12placeholders.t"
- "t/20savepoints.t"
- "t/30unicode.t"
- )
- if [[ ! -v DBI_DSN ]]; then
- ewarn "Functional database tests disabled due to lack of configuration."
- ewarn "Please set the following environment variables values pertaining to a"
- ewarn "pre-configured Postgres installation in order for tests to work:"
- ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
- ewarn " ( eg: dbi:Pg:dbname=testdb )"
- ewarn " DBI_USER - A Postgres Database Username"
- ewarn " DBI_PASS - A Postgres Database Password"
- ewarn ""
- ewarn "For details, visit:"
- ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
- perl_rm_files "${LIVEDB_TESTS[@]}"
- fi
- # Parallel testing breaks database access
- DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
-
-}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
index 948ca5935439..2357cf85ff87 100644
--- a/dev-perl/DBD-Pg/Manifest
+++ b/dev-perl/DBD-Pg/Manifest
@@ -1,7 +1,3 @@
-DIST DBD-Pg-3.10.0.tar.gz 268414 BLAKE2B da6ac65519632aa95ee2554607d5e26820527042873ab78a9e40e671902b1b8e2fe39f37e44b15cf3db8eda243e57c7fab9077d4a08ec7f3c312825609fbc805 SHA512 46c985bbdeeed4ef60d6fe06034fa0959df288f2b9bbd434e2716676a3cb7a1ded168a3cf87a6a82eb397eb8edcc023c0b85483e948ce31abcac64a1919580ba
-DIST DBD-Pg-3.14.2.tar.gz 282024 BLAKE2B a8121a2c97b1e095576c40b9b305f0ac21b3a8062efd3ac9684ef68346fc9fb0e4384780dc79b7bb5b6b188825dbd2f3da4765eeeb0208c3bef4db28543f9021 SHA512 341df267a7dc1e28f8c71c1b03cb485caf5c9c2ba95a801f7e855ef8c2fb2ed2df2f3cef804fd36072ee5570d30b399f6fba7516216f7d24186c5b6eeb5d5c52
DIST DBD-Pg-3.15.0.tar.gz 284379 BLAKE2B e3d8d5a2e3339c88f92dc24cca47296b8b2e597dcb81f2645180dd90b27873f209728dc0ac320e493b573c73efb54292e89370a628fc304bf319e237e04b1912 SHA512 67912da5cda42d198cdffa3f5c93267ed9da681c837fd8a9b8c6a13873a461b1123ce0a8e1f4f4398264f57ead35950b4945018e6cead14c903a809a298aecb9
-EBUILD DBD-Pg-3.10.0.ebuild 2717 BLAKE2B 0dc600cd44185a34fe87846101ead421ce894315590bb1503be18c109266d5437976d16164662c06528e137b842c5ee5d3938794d61acb843e385efe109398c4 SHA512 56ab20907456ba3b05ee47cd7d0ea69a00752507cd2aaf21360a535d951f2b473e8b7d8a0c3cafb6f67465e1719fcdbbfc2668d3449e57578b8e69f5d848d35f
-EBUILD DBD-Pg-3.14.2.ebuild 2821 BLAKE2B 4c878c064a58c0ffaf54a76918ffcad6826d127264aa0c8d1a7624ace311e7f85b3e657b0593be4e19112a60a59a8b6bc9c04e076f87694941c1a44d0847050f SHA512 a26cc4c6076efccfa930e54877ee801566e3ff522c15b39248f19f967d161eba68f30c35cf9112c24c0a13c993693f9ab3c3f2abb4434238498b70c1da7cb3d4
EBUILD DBD-Pg-3.15.0.ebuild 2821 BLAKE2B 4c878c064a58c0ffaf54a76918ffcad6826d127264aa0c8d1a7624ace311e7f85b3e657b0593be4e19112a60a59a8b6bc9c04e076f87694941c1a44d0847050f SHA512 a26cc4c6076efccfa930e54877ee801566e3ff522c15b39248f19f967d161eba68f30c35cf9112c24c0a13c993693f9ab3c3f2abb4434238498b70c1da7cb3d4
MISC metadata.xml 446 BLAKE2B 428b5b91a84ab6026f482e2e3404f7b43a1557d16f42340453d927b4ea676caa3ab422705ea99439fd6369a43af9f2dcd0d7d3ec6a42f82b9e8df17cd2642a1a SHA512 23e05469a61761595bc52b6798d152dfc82b42a4ce1ed8010cd17b6343557ef92433cd31c00102098ed698ed0fd0260e3d165c926b9ce3de91f52112c9b40684